Введение

Программа NDemia CashMatic KioskBrowser разработана для организации работы терминалов приёма платежей.
NDemia CashMatic KioskBrowser является расширенной оболочкой для Internet Explorer и, соответственно, включает в себя всю функциональность Internet Explorer как средства просмотра HTML-контента, включая поддержку встроенных в Internet Explorer скриптовых языков (javascript и Visual Basic Script). Никаких специальных ограничений на контент не накладывается, поэтому вполне нормально поддерживается и работа скриптов серверной стороны (PHP, ASP и другие подобные технологии).
С другой стороны, NDemia CashMatic KioskBrowser поддерживает работу со специализированным оборудованием, характерным для платёжных терминалов и не характерным для обычных компьютеров - купюроприёмник, чековый принтер, фискальный регистратор.
Кроме того, NDemia CashMatic KioskBrowser организует порядок просмотра контента более жёстко, чем обычные веб-браузеры, ограничивая возможные действия пользователя по управлению навигацией, а также выполняя переходы на фиксированные адреса при определённых сигналах от специального оборудования. Вместе с тем разработчику контента предоставляются дополнительные возможности по организации сеанса работы пользователя на клиентской стороне, что уменьшает зависимость работы пользовательского интерфейса от стабильности связи с сервером и сокращает дополнительный трафик, несущественный с точки зрения конечного результата. Управление сценарием приёма платежа на клиентской стороне является положительным моментом и с точки зрения информационной безопасности - уменьшается количество закрытых данных, которые требуется передавать по каналам связи.
И наконец, NDemia CashMatic KioskBrowser предоставляет возможность подключения разработанных сторонними программистами COM-объектов, реализующих соответствующие интерфейсы расширения.


Системные требования

Для работы NDemia CashMatic KioskBrowser требуется:
  • компьютер (или терминал), работающий под управлением Microsoft Windows версии не ниже Windows 2000. Базовой системой для NDemia CashMatic является Windows XP, гарантируется поддержка Windows Vista и Windows 7, использование других версий может потребовать дополнительного сопровождения. На компьютере (терминале) должен быть установлен Microsoft Internet Explorer v.6 или Windows Internet Explorer v.7 и выше.
  • соединение с интернетом (как минимум, на время регистрации программного продукта и активации лицензионного ключа) - хотя бы сеансовое низкоскоростное.

NDemia CashMatic KioskBrowser поддерживает работу следующих типов оборудования:
  • купюроприёмник, работающий по протоколу CCNET или ICT004;
  • чековый принтер, работающий через COM-порт (RS232) (любая модель, для которой известна система команд);
  • фискальный регистратор производства "Штрих-М" (любая модель, поддерживаемая драйвером «Штрих-М: Драйвер ФР» - см. http://www.shtrih-m.ru).


Профессиональные требования

Для установки и эксплуатации программного продукта NDemia CashMatic KioskBrowser достаточно общей компьютерной грамотности:
  • умение устанавливать и удалять программы;
  • умение находить, открывать, копировать и переименовывать папки и файлы на диске компьтера;
  • понимание вопросов подключения и настройки COM-портов (RS232) - хотя бы в общих чертах;
  • владение командной строкой и редактором реестра желательно, но в общем не обязательно.

Программный продукт NDemia CashMatic KioskBrowser по своему назначению заранее предполагает необходимость доработки под конкретные задачи его покупателей. Поэтому кроме уровня установки и эксплуатации рассматривается уровень разработки.
Для разработки прикладных систем на основе NDemia CashMatic KioskBrowser требуется:
  • владение HTML хотя бы в общих чертах;
  • владение javascript или Visual Basic в рамках программирования для Internet Explorer;
  • умение читать гипертекстную техническую документацию;
  • владение PHP или другой технологией программирования серверной стороны для NDemia CashMatic непосредственно не требуется, но предполагается, что разработчик системы в целом такими знаниями должен обладать.


Установка

Установка программного продукта NDemia CashMatic KioskBrowser выполняется запуском инсталлятора - файла Install.CashMatic.exe.

Текущую версию программного продукта NDemia CashMatic всегда можно загрузить по адресу http://www.ndemia.com/CashMatic/download.


Порядок установки

Программный продукт устанавливается в папку программ Windows (путь "\Program Files\NDemia\CashMatic").
Для начала установки требуется только подтвердить лицензионное соглашение.

По умолчанию принтер и купюроприёмник настраиваются в режим "Не подключено".
После установки требуется выполнить:
  • настройку подключения купюроприёмника;
  • регистрацию программного продукта.

Для запуска инсталлятора требуются права локального администратора.
Если выполняется повторная переустановка, то инсталлятор перед началом попытается закрыть все известные ему запущенные компоненты программного продукта. Если закрыть какую-либо из программ не удастся, установка всё равно выполнится, но по результату весьма вероятно будет запрошена перезагрузка операционной системы (см. Завершение установки).


Особенности повторной установки

Если программный продукт NDemia CashMatic уже был установлен на компьютере или на терминале, то повторная установка несколько отличается по алгоритму выполения (хотя с точки зрения пользователя эти отличия практически незаметны). Запуск инсталлятора выполняется так же (Install.CashMatic.exe), однако в процессе установки инсталлятор будет стремиться сохранить все текущие настройки, записанные в реестре, а также будет избегать перезаписи файлов, которые могли быть изменены пользователем. Если уже существующий на диске файл отличается от устанавливаемого (по признакам длины и времени последней записи), и по этому файлу у инсталлятора нет предписания переустанавливать его безусловно, то пользователю будет задан вопрос, как поступать при вероятной перезаписи данных.

При ответе "Да" все существующие на диске файлы данных, не соответствующие устанавливаемым, будут копироваться в отдельную папку, с именем вида "\Program Files\NDemia\CashMatic\Backup.NNN", где NNN-число, при каждой переустановке при необходимости создаётся новая папка, номер в имени увеличивается на единицу, начиная с 000. Таким образом, файлы, созданные или изменённые пользователем, не будут безвозвратно потеряны (хотя их восстановление из архивной папки потребует некоторых действий от пользователя).
При ответе "Нет" все устанавливаемые файлы, не соответствующие уже существующим на диске, будут копироваться в отдельную папку, с именем вида "\Program Files\NDemia\CashMatic\Update.NNN", где NNN-число, при каждой переустановке при необъодимости создаётся новая папка, номер в имени увеличивается на единицу, начиная с 000. Таким образом, файлы, созданные или изменённые пользователем, остаются на прежних местах, но у пользователя остаётся возможность просмотреть новые файлы, которые не были установлены.
В конце установки, при которой создалась новая папка Backup или Update, будет выдано сообщение вида:

или


Завершение установки

Примечание: Кнопка "Показать последние изменения" может быть скрыта (если файл последних изменений отсутствует)

Совместимость: Кнопка "Показать последние изменения" поддерживается, начиная с NDemia CashMatic версии 2.6.0

По завершению установки инсталлятор может запросить перезагрузку Windows.

Обратите внимание: если перезагрузка запрашивается, то это означает, что некоторые файловые операции были отложены, поэтому перезагрузка действительно требуется. Если Вы откажетесь от перезагрузки, то имейте в виду, что переустановка продукта ещё не завершилась, и некоторые его компоненты могут работать неправильно. Если Вы отказались от перезагрузки, то Вы не должны заново запускать установку (инсталлятор) до перезагрузки, поскольку отложенные файловые операции всё равно будут выполнены системой при следующем запуске, что может в результате привести к общей некорректности установки.
После успешной установки или переустановки (без перезагрузки) запустится Панель управления NDemia CashMatic, а также появится значок [image] NDemia CashMatic в панели задач Windows.

Если к компьютеру или терминалу подключен купюроприёмник, то настоятельно рекомендуется настроить параметры подключения купюроприёмника до выполнения регистрации программного продукта или активации лицензионного ключа.


Если потребовалась активация

Если после установки Вы видите в панели задач Windows сообщение "Требуется активация лицензионного ключа", то это говорит о том, что Ваша лицензия заблокирована и программный продукт находится в неработоспособном состоянии. Это может произойти по следующим причинам:
  • программный продукт уже был установлен на Вашем компьютере или терминале, и испытательный срок истёк;
  • программный продукт ранее был установлен на Вашем компьютере или терминале, а затем был удалён, но не полностью (испытательный срок при этом возможно ещё не истёк).

В этом положении, если у Вас есть лицензионный ключ, то нужно его активировать (см. Активация лицензионного ключа).
Если у Вас нет лицензионного ключа:
  • если испытательный срок уже истёк, но Вы хотели бы продолжать использовать программный продукт NDemia CashMatic на постоянной основе, Вам нужно приобрести лицензионный ключ.
  • если испытательный срок ещё не истёк и Вы ещё не приняли решение о приобретении лицензии на программный продукт NDemia CashMatic, сделайте следующее:
    • если Вы изменяли какие-либо файлы в папке программы ("\Program Files\NDemia\CashMatic") - html-страницы, шаблоны печати и т.п., то сохраните их в отдельной папке, вне пути "NDemia\CashMatic";
    • сразу после установки удалите программный продукт, воспользовавшись средством "Установка и удаление программ" панели управления Windows. При удалении обязательно выберите пункт "Полностью удалить все файлы и данные" (подробнее см. Удаление);
    • запустите ещё раз установку (инсталлятор Install.CashMatic.exe).


Настройка (Панель управления NDemia CashMatic)

Главным средством настройки параметров программного продукта NDemia CashMatic является приложение Панель управления NDemia CashMatic. Панель управления может быть вызвана следующими способами:
  • из меню Пуск (Все программы\NDemia\CashMatic\Панель управления NDemia CashMatic)
  • из меню значка NDemia CashMatic в панели задач Windows
  • из панели управления Windows (значок NDemia CashMatic)
  • папка установки программы, файл CMControl ("\Program Files\NDemia\CashMatic\CMControl.exe")

(все способы запуска равнозначны)

В Панели управления NDemia CashMatic имеются следующие вкладки:
    Лицензия
    здесь можно просмотреть текст Лицензионного Соглашения, узнать текущее состояние лицензии, вызвать программу регистрации программного продукта и активации лицензионного ключа;
    Терминал
    здесь настраиваются общие параметры терминала, в текущей версии: имя терминала (по умолчанию равно имени компьютера Windows, но может отличаться), программный счётчик принятых купюр;
    Интерфейс
    здесь настраиваются различные параметры графического интерфейса (приложение NDemia CashMatic KioskBrowser);
    Купюроприёмник
    здесь настраиваются параметры подключения купюроприёмника;
    Принтер
    здесь настраиваются параметры подключения принтера или фискального регистратора.


Страница "Лицензия"

    Лицензионное соглашение
    здесь представлен текст Лицензионного Соглашения об использовании программного продукта NDemia CashMatic на Вашем компьютере. Используйте полосу прокрутки для полного просмотра текста. Поддерживаются операции выделения и копирования текста.
    Состояние лицензии
    здесь показано текущее состояние лицензии (текстовое сообщение в читаемом виде). Используйте полосу прокрутки для полного просмотра текста. Поддерживаются операции выделения и копирования текста. Если данное сообщение указывает, что лицензия заблокирована или к программному продукту применены какие-либо ограничения, нажмите кнопку "Регистрация продукта и активация ключа".
    Регистрация продукта и активация ключа
    по этой кнопке запускается программа "Регистрация NDemia CashMatic", которая позволяет, кроме указанных на кнопке действий, выполнить прямой ввод лицензионного ключа и/или лицензионного файла данных, а также получить сведения о приобретении программного продукта. (см. Регистрация и Активация)


Страница "Терминал"

    Терминал
    имя, идентифицирующее данный терминал в Вашей платёжной системе (по умолчанию равно имени компьютера).
    Использовать счётчик купюр
    флаг, включающий программный счётчик купюр (ВНИМАНИЕ: в некоторых случаях значение программного счётчика может не соответствовать фактическому заполнению ёмкости купюроприёмника. Для точного соответствия рекомендуется использовать приложение NDemia CashMatic KioskBrowser или службу NDemia CashMatic Kiosk в постоянном режиме, снимать стекер только при работающем компьютере и вынимать все купюры при каждом вскрытии).
    Текущее значение
    целое число, значение программного счётчика купюр.
    Сброс
    сброс программного счётчика купюр (ВНИМАНИЕ: если на самом деле в стекере остались неизъятые купюры, то значение счётчика будет неверно отражать фактическое заполнение стекера).
    Предельное значение
    ёмкость стекера (максимальное число принятых купюр) - информационное значение, фактически на работу купюроприёмника этот параметр не влияет. Подробности см. в Руководстве прикладного программиста.


Страница "Интерфейс"

    Автозапуск при загрузке системы
    установка этого флажка включает автоматический запуск графического интерфейса NDemia CashMatic при загрузке операционной системы.
    Открывать поверх всех окон
    открывать графический интерфейс поверх остальных окон. Этот режим лишает возможности большинство других программ выводить свои окна и сообщения поверх экрана NDemia CashMatic.
    Отдельный рабочий стол
    запускать графический интерфейс NDemia CashMatic на отдельном рабочем столе. Этот режим полностью блокирует для всех остальных программ возможность выводить изображения поверх экрана NDemia CashMatic. При включении этого режима следует иметь в виду, что он блокирует переключение окон с помощью Alt-Tab, Панели задач Windows, Диспетчера задач Windows и т.п. Единственная возможность закрыть окно NDemia CashMatic - это нажать Alt-F4 на клавиатуре. (ВНИМАНИЕ: если программа установлена на терминале без клавиатуры, включен автозапуск при загрузке и запуск на отдельном рабочем столе, то нет вообще никакой возможности запустить что-либо, кроме NDemia CashMatic, или препятствовать запуску NDemia CashMatic)
    Скрывать курсор мыши
    установка этого флажка включает гашение курсора мыши в окне интерфейса (актуально для сенсорных экранов).
    Использовать звуковые сообщения
    установка этого флажка включает использование звуковых сообщений при вводе платежей.
    Озвучивать сумму платежа
    установка этого флажка включает произнесение вслух введённой денежной суммы после ввода каждой купюры. Следует иметь в виду, что это ухудшает конфиденциальность процедуры ввода платежа для плательщика.
    Игнорировать отсутствие купюроприёмника
    установка этого флажка разрешает интерфейсу нормально работать при отсутствии купюроприёмника, ввод денег в этом случае может симулироваться программно командой SIMCASH (см. Руководство прикладного программиста). На странице Купюроприёмник должен быть выбран режим "Не подключен" и разрешена симуляция ввода купюр.
    Игнорировать отсутствие принтера
    установка этого флажка разрешает интерфейсу нормально работать при отсутствии связи с принтером. Невозможность напечатать чек при этом игнорируется.
    Допускать отсутствие бумаги
    установка этого флажка разрешает интерфейсу нормально работать при отсутствии бумаги в принтере. Невозможность напечатать чек при этом игнорируется, но отсутствие принтера или связи с принтером может восприниматься как ошибка, в зависимости от других параметров программы (С точки зрения программиста при установленном флажке отказ PaperEnd перестаёт считаться ошибкой, см. Руководство прикладного программиста).

    Совместимость: Флажок "Допускать отсутствие бумаги" поддерживается, начиная с NDemia CashMatic версии 2.6.2

    Использовать службу NDemia CashMatic Kiosk
    установка этого флажка предписывает интерфейсу использовать вызовы службы NDemia CashMatic Kiosk, а не работать с оборудованием напрямую. Использование службы не обязательно, но требуется для поддержки команд, перечисленных в Руководстве прикладного программиста, раздел Дополнительные сведения (например, SIMCASH или BVSIMEVENT).

    Совместимость: в NDemia CashMatic версий 2.6.2, 2.7.0 и 2.7.1 использование службы NDemia CashMatic Kiosk по умолчанию отключается инсталлятором при первичной (новой) установке под Windows Vista и выше.

    Игнорировать симуляцию ввода купюр
    установка этого флажка предписывает интерфейсу игнорировать программно-симулированный ввод купюр (см. Руководство прикладного программиста).


Страница "Купюроприёмник"

    Протокол устройства
    выбор протокола управления купюроприёмником (CCNET - купюроприёмники производства CashCode (http://cashcode.com), ICT004 - купюроприёмники производства International Currency Technologies (http://www.ictgroup.com.tw))
    Порт
    флажок использования последовательного порта для подключения купюроприёмника. (Если этот флажок снят, то это соответствует отключению купюроприёмника - даже если он реально подключен и работает, программа не будет иметь с ним связи)
    При включении флажка "Порт" активируются следующие элементы управления:
    • список последовательных портов, имеющихся в составе оборудования Вашего компьютера (нужно указать порт подключения купюроприёмника).

      Совместимость: в NDemia CashMatic версий ранее 2.7.1 последовательные порты с номерами выше COM9 не поддерживаются, хотя и отображаются в списке доступных портов.

    • скорость обмена по последовательному порту (в раскрывающемся списке - стандартный ряд скоростей, в бит/с. Нужно выбрать скорость, соответствующую Вашему купюроприёмнику. Для CCNET допустимые значения: 9600 или 19200, для ICT004: только 9600)
    • настройка метода управления потоком интерфейса RS-232 для порта подключения купюроприёмника (в раскрывающемся списке - поддерживаемые режимы).

      Совместимость: Метод управления потоком XON-XOFF не поддерживается, для протокола CCNET - начиная с NDemia CashMatic версии 2.7.0, для протокола ICT004 - начиная с NDemia CashMatic версии 2.7.1.

    • кнопка "Тест" - проверка связи с купюроприёмником через выбранный последовательный порт. По кнопке "Тест" параметры подключения временно (на время выполнения теста) переключаются на указанные на странице Купюроприёмник, делается попытка получения идентификационных данных купюроприёмника (только для CCNET), далее купюроприёмник на 10 секунд переводится в режим приёма купюр. Если не выявлено никаких ошибок, и купюроприёмник принял купюру и правильно опознал тип купюры (или хотя бы по видимым признакам переходил в режим приёма купюры), то это означает, что все параметры указаны правильно.
      Примечание: если программный продукт NDemia CashMatic уже был ранее зарегистрирован, но по техническим причинам после этого была выполнена замена купюроприёмника CCNET, то тест приёма купюры может завершиться выдачей сообщения «Идентификация купюроприёмника не соответствует лицензионным данным. Требуется активация лицензионного ключа.»:

      Это означает, что идентификация купюроприёмника не соответствует лицензионным данным, поэтому приём купюр не работает, хотя лицензия считается нормальной. Для исправления ситуации требуется повторная активация лицензионного ключа. При нажатии "Ok" все необходимые настройки будут сохранены, и запустится соответствующая программа (см. Активация).

      Совместимость: в NDemia CashMatic версий ранее 2.7.2 указанное сообщение не выдаётся, тест купюроприёмника в соответствующем случае просто заканчивается с результатом "Не удалось принять купюру (ошибка 3 "BUSY")".

      Совместимость: в NDemia CashMatic версий ранее 2.7.2 изменение версии прошивки купюроприёмника CCNET приравнивается к замене купюроприёмника.

    Разрешить симуляцию состояния
    установка этого флажка разрешает программную симуляцию состояний купюроприёмника (например, с помощью команды BVSIMEVENT - см. Руководство прикладного программиста). При нормальной эксплуатации рекомендуется отключить (в целях повышения безопасности).
    Разрешить симуляцию ввода купюр
    установка этого флажка разрешает программную симуляцию ввода купюр (например, с помощью команды SIMCASH - см. Руководство прикладного программиста). При нормальной эксплуатации рекомендуется отключить (в целях повышения безопасности).


Страница "Принтер"

Настройка подключения принтера;
Параметры вывода на печать;
Система команд принтера;
Поддержка фискального регистратора.


Настройка подключения принтера

Не подключен;
Порт;
Файл;
Фискальный регистратор.


Не подключен

    Не подключен
    это положение переключателя соответствует отключению принтера (даже если он реально подключен и работает, программа не будет иметь с ним связи)


Порт

    Порт
    это положение переключателя соответствует подключению принтера к последовательному порту компьютера.
    При выборе режима "Порт" активируются следующие элементы управления:
    • список последовательных портов, имеющихся в составе оборудования Вашего компьютера (нужно указать порт подключения принтера).
    • скорость обмена по последовательному порту (в раскрывающемся списке - стандартный ряд скоростей, в бит/с. Нужно выбрать скорость, соответствующую Вашему принтеру. (обычные значения - 9600 или 19200))
    • настройка метода управления потоком интерфейса RS-232 для порта подключения принтера.
    • кнопка "Тест" - пробная печать проверочного текста на Ваш принтер. По кнопке "Тест" параметры подключения временно (на время выполнения теста) переключаются на указанные на странице Принтер. Если текст напечатался, и параметры шрифтов соответствуют их названиям (см. напечатанный текст), то это означает, что всё настроено правильно.
      Тест принтера состоит в выводе на печать файла PrintTest (файл располагается в папке установки программы, т.е. "\Program Files\NDemia\CashMatic\PrintTest"). Это обычный текстовый файл, русский язык в кодировке CP1251, для просмотра и правки можно использовать Блокнот Windows.
      Известно, что на принтере Star TUP-900 есть проблема с выполнением этого теста - слишком длинная строка сбивает печать. В этой связи, если Вы используете указанный принтер, то удалите оригинальный файл PrintTest и переименуйте PrintTest-star-tup900 в PrintTest.
      • Параметры
      настройка параметров вывода на печать (см. Параметры вывода на печать)
      Команды
      настройка системы команд управления принтером (см. Система команд принтера)


Файл

    Файл
    это положение переключателя включает вывод чека в текстовый файл вместо принтера (включая управляющие команды). В этом случае в поле ввода требуется указать имя файла.
    При выборе режима "Файл" активируются следующие элементы управления:
    • поле ввода имени файла (требуется указание полного пути).
    • кнопка "Выбрать (обзор)" - вызов диалога выбора файла принтерного вывода.
      • Параметры
      настройка параметров вывода на печать (см. Параметры вывода на печать)
      Команды
      настройка системы команд управления принтером (см. Система команд принтера)


Фискальный регистратор

    Фискальный регистратор
    это положение переключателя предписывает в качестве принтера использовать фискальный регистратор (режим поддерживается только если на компьютере установлен «Штрих-М: Драйвер ФР» - см. http://www.shtrih-m.ru)
    При выборе режима "Фискальный регистратор" активируются следующие элементы управления:
      Параметры
      настройка параметров использования фискального регистратора (см. Параметры фискального регистратора)
      Свойства
      вызов окна свойств фискального регистратора (ВНИМАНИЕ: окно свойств поддерживается самим драйвером фискального регистратора (не входит в комплект NDemia CashMatic, входит в комплект оборудования), документацию см. на сайте www.shtrih-m.ru)


Параметры вывода на печать

Параметры вывода на печать для режимов принтера "Порт" и "Файл" (для фискального регистратора см. Параметры фискального регистратора).

Этот диалог настраивает параметры вывода при печати на принтер или в файл. Он вызывается со страницы настройки принтера Панели управления NDemia CashMatic.
    Опрашивать состояние принтера
    этот флажок включает опрос состояния принтера перед печатью чека (требуется для отслеживания таких событий, как конец бумаги, открытие крышки принтера и т.п.)
    Для выполнения опроса состояния принтера требуется правильная настройка команд "Статус печати" (STATUS_PRINT), "Статус рулона" (STATUS_ROLL) и соответствующих битовых масок - см. Система команд принтера.
    Флажок "Опрашивать состояние принтера" может быть установлен и при выводе в файл. Эта установка требуется для отладочной симуляции отсутствия бумаги (команда CONFIG PrinterSimulateNoPaper, см. Руководство прикладного программиста)
    Кодировка OEM(CP866) при выводе
    этот флажок включает преобразование кодировки текста перед выводом на печать Windows(CP1251) -> OEM(CP866), требуется для некоторых моделей принтеров, у которых русский язык прошит в кодировке CP866.
    Использовать коды форматирования
    этот флажок включает форматирование текста при печати (если форматирование выключено, то все коды в тексте чека пропускаются без обработки (не удаляются)). При использовании шаблонов чеков отключение форматирования обрабатывается как простое удаление кодов - см. Руководство прикладного программиста.


Система команд принтера

Настройка системы команд;
Описание поддерживаемых команд.


Настройка системы команд принтера

В этом диалоге настраивается система команд, используемая в NDemia CashMatic для управления принтером, подключенным к Вашему компьютеру.
По умолчанию при первичной установке команды настраиваются по стандарту ESC/P (Epson Standard Codes for Printing). К сожалению, этот стандарт достаточно широко трактуется различными производителями (заявляющими его поддержку), поэтому подстройка команд почти наверняка потребуется. Программный продукт комлектуется набором файлов, описывающих команды некоторых популярных чековых принтеров. Все эти файлы размещаются в папке установки программы ("\Program Files\NDemia\CashMatic")
Система команд, устанавливаемая по умолчанию инсталлятором при первичной установке, описана в файле PrinterCommands.txt.
Файлы с уже подготовленными системами команд имеют имена вида PrinterCommands-<производитель>-<модель>.txt.
Если используется принтер, для которого нет готового файла, описать команды можно в диалоге "Система команд принтера". Сведения о командах для этого нужно найти в документации Вашего принтера (можно просто написать в ООО НДемиа, что Вам нужна в NDemia CashMatic поддержка принтера такой-то модели такого-то производителя).

ВНИМАНИЕ - при повторной установке: инсталлятор не изменяет настроенную на терминале систему команд (полагая, что ранее всё уже было правильно настроено). Кроме того, устанавливаемые файлы PrinterCommands-*.txt рассматриваются как файлы данных, которые могли быть изменены пользователем, поэтому переустановка файлов PrinterCommands-*.txt выполняется по соответствующему алгоритму - см. Особенности повторной установки Переустановка относится только к файлам данных и никак не влияет на действующую систему команд. Для изменения настройки системы команд Вы должны после переустановки воспользоваться либо диалогом настройки системы команд принтера, либо командой CONFIG (см. CONFIG PrinterCommands).

В диалоге "Система команд принтера" команды вводятся побайтно, разделитель - пробел, префикс '$' означает шестнадцатеричную систему записи числа, значение больше 255 ($FF) воспринимается как ошибочное.
Некоторые значения (NO_PAPER, OFFLINE, NO_ROLL, NEAR_PAPER_END) на самом деле не являются командами, это битовые маски для проверки соответствующих условий по результату опроса статуса (см. Описание поддерживаемых команд).
Ряд команд являются парными (например BOLD_ON/BOLD_OFF) - если задана одна команда, то обязательно должна быть задана другая (даже если их коды совпадают)
По кнопке "Сохранить в файл" можно записать текущее содержимое диалога в текстовый файл с именем по Вашему усмотрению, синтаксис файла аналогичен PrinterCommands.txt.
Кнопкой "Загрузить из файла" можно открыть готовый или ранее сохранённый файл.
Пустое значение в поле ввода соответствует незаданной или неподдерживаемой команде. Как отдельные, так и вообще все команды могут быть пустыми.

Совместимость: Значения STATUS_TICKET, TICKET_PRESENT, TICKET_EJECT, TICKET_RETRACT добавлены в диалог настройки системы команд принтера в NDemia CashMatic версии 2.6.0.


Описание поддерживаемых команд

В текущей версии NDemia CashMatic поддерживаются следующие команды (•):
Название | Обозначение | Комментарий | Значение ESC/P | Значение Citizen-PPU700 (••) | Значение Custom-VKP80 | Значение Star-TUP900 (•••) | Значение SysFuture-AV268
Инициализация | INIT | Команда программного сброса принтера (подаётся перед печатью каждого чека). | $1B $40 | $1B $40 $1B $74 $7 | $1B $40 | $1B $40 $1B $1D $74 10 | -
Отрезать чек | CUT | Команда отрезания чека (подаётся после печати каждого чека). | $0C | $1D $56 66 0 | $1B $69 $1D $65 $03 $0C | $1B $64 3 | $1B $6D
Статус печати | STATUS_PRINT | Команда получения статуса печати. В результате этой команды принтер должен вернуть однобайтное значение, по которому масками OFFLINE и NO_PAPER определяются неготовность к печати и наличие бумаги. | - | $10 4 2 | $10 4 2 | $5 | $1B $76
Маска "Нет бумаги" | NO_PAPER | Маска состояния "Нет бумаги". Состояние "Нет бумаги" детектируется по совпадению одного или нескольких единичных битов в данной маске и в значении, возвращённом принтером по команде STATUS_PRINT. См. также состояние "Нет рулона". | - | $20 | $20 | $8 | $4
Маска "Оффлайн" | OFFLINE | Маска состояния "Оффлайн" (неготовность к печати). Состояние "Оффлайн" детектируется по совпадению одного или нескольких единичных битов в данной маске и в значении, возвращённом принтером по команде STATUS_PRINT. | - | $4C | $4C | $4 | $6A
Статус рулона | STATUS_ROLL | В результате этой команды принтер должен вернуть однобайтное значение, по которому масками NO_ROLL и NEAR_PAPER_END определяются наличие/отсутствие рулона бумаги, а также определяется состояние "Мало бумаги" (конкретное значение, сколько бумаги считать как "мало", задаётся собственными настройками принтера). | - | $10 4 4 | $10 4 4 | $4 | -
Маска "Нет рулона" | NO_ROLL | Маска состояния "Нет рулона". Состояние "Нет рулона" детектируется по совпадению одного или нескольких единичных битов в данной маске и в значении, возвращённом принтером по команде STATUS_ROLL. Состояние "Нет рулона" для прикладной программы логически приравнивается к состоянию "Нет бумаги", различия этих состояний определяются конкретной моделью принтера и конструкцией механизма подачи бумаги. Если контроль состояния рулона поддерживается принтером и надёжно работает, то обработка "Нет рулона" более предпочтительна, чем "Нет бумаги" - это позволяет прикладной программе "предвидеть" сбой печати, который фактически ещё не произошёл. | - | $60 | $60 | - | -
Маска "Мало бумаги" | NEAR_PAPER_END | Маска состояния "Мало бумаги" (приближение конца бумаги). Состояние "Мало бумаги" детектируется по совпадению одного или нескольких единичных битов в данной маске и в значении, возвращённом принтером по команде STATUS_ROLL. Конкретное значение, сколько бумаги считать как "мало", задаётся собственными настройками принтера. | - | $0C | $0C | $24 | -
Вкл. подчёркивание | UNDERLINE_ON | Команда включения печати подчёркнутого текста (должна задаваться так же парная команда UNDERLINE_OFF). | $1B $2D 49 | $1B $2D 49 | $1B $2D 49 | $1B $2D 49 | $1B $2D 49
Выкл. подчёркивание | UNDERLINE_OFF | Команда выключения печати подчёркнутого текста (должна задаваться так же парная команда UNDERLINE_ON). | $1B $2D 48 | $1B $2D 48 | $1B $2D 48 | $1B $2D 48 | $1B $2D 48
Вкл. наклон | ITALIC_ON | Команда включения печати курсивом (наклонным шрифтом) (также должна задаваться парная команда ITALIC_OFF). | $1B $34 | - | $1B $34 49 | - | -
Выкл. наклон | ITALIC_OFF | Команда выключения печати курсивом (наклонным шрифтом) (также должна задаваться парная команда ITALIC_ON). | $1B $35 | - | $1B $34 48 | - | -
Вкл. жирный | BOLD_ON | Команда включения печати жирным шрифтом (также должна задаваться парная команда BOLD_OFF). | $1B $45 | $1B $45 49 | $1B $45 49 | $1B $45 | $1B $45 49
Выкл. жирный | BOLD_OFF | Команда выключения печати жирным шрифтом (также должна задаваться парная команда BOLD_ON). | $1B $46 | $1B $45 48 | $1B $45 48 | $1B $46 | $1B $45 48
Вкл. инвертирование | INVERT_ON | Команда включения инверсной печати ("белым по чёрному") (также должна задаваться парная команда INVERT_OFF). | - | $1D $42 49 | $1D $42 49 | $1B $34 | $1B $7B 49
Выкл. инвертирование | INVERT_OFF | Команда выключения инверсной печати ("белым по чёрному") (также должна задаваться парная команда INVERT_ON). | - | $1D $42 48 | $1D $42 48 | $1B $35 | $1B $7B 48
Статус чека | STATUS_TICKET | Команда проверки присутствия выходного чека (применима при наличии при наличии соответствующего механизма удержания чека). В результате этой команды принтер должен вернуть однобайтное значение, по которому маской TICKET_PRESENT определяется наличие напечатанного чека на выходе принтера. | - | $1D $72 49 | $1D $65 $06 | - | -
Маска "Чек присутствует" | TICKET_PRESENT | Маска состояния "Чек присутствует" (применима при наличии соответствующего механизма удержания чека) Присутствие чека детектируется по совпадению одного или нескольких единичных битов в данной маске и в значении, возвращённом принтером по команде STATUS_TICKET. См. также команды "Вытолкнуть чек" (TICKET_EJECT) и "Втянуть чек" (TICKET_RETRACT). | - | $08 | $08 | - | -
Вытолкнуть чек | TICKET_EJECT | Команда выталкивания удерживаемого чека (применима при наличии соответствующего механизма движения чека) См. также команду "Втянуть чек" (TICKET_RETRACT). | - | - | $1D $65 $05 | - | -
Втянуть чек | TICKET_RETRACT | Команда втягивания удерживаемого чека (применима при наличии соответствующего механизма движения чека) См. также команду "Вытолкнуть чек" (TICKET_EJECT). | - | $1D $52 $30 | $1D $65 $02 | - | -

(•) разные (по версии) выпуски NDemia CashMatic могут содержать в составе дистрибутива подборки команд принтеров, отличающиеся от указанных (как по составу моделей принтеров, так и по значениям кодов команд).
(••) в стандартную комплектацию входит также отдельный файл команд для принтера "Citizen CBM-1000".
(•••) отдельный файл команд для принтера "Star TUP-900 ESC/POS emulation" поставляется с NDemia CashMatic версии от 2.6.0 и выше.


Поддержка фискального регистратора

Параметры;
Свойства.


Параметры

Этот диалог описывает параметры использования фискального регистратора. Он вызывается со страницы настройки принтера Панели управления NDemia CashMatic.
В NDemia CashMatic поддерживаются фискальные регистраторы производства "Штрих-М" (http://www.shtrih-m.ru), которые комплектуются собственным драйвером с достаточно развитой настройкой ("Драйвер ФР"). Диалог "Параметры фискального регистратора" является настройкой именно стороны NDemia CashMatic, т.е. содержит параметры, с которыми приложение обращается к драйверу.
    Пароль оператора
    пароль, с которым NDemia CashMatic вызывает методы драйвера, требующие указания пароля. В "Драйвере ФР" должен быть настроен такой же пароль оператора. Если пароль не вводится в это поле, то по нажатию Ok или "Применить" остаётся действующим предыдущее значение.
    Пароль повторно
    поле для повторного ввода пароля оператора. Если пароль оператора не изменяется в текущем вызове диалога, то вводить его не нужно (остаётся действующим предыдущее значение).
    Номер отдела (секции)
    номер отдела, к которому будут относиться все фискализированные продажи, сделанные на этом терминале (более подробно см. свойство Department в документации по фискальному регистратору на сайте www.shtrih-m.ru)
    Лимит продажи на чек
    Максимальная стоимость одной позиции продажи, допустимая в фискальном чеке. Этот параметр позволяет избежать неприятностей, связанных с фискализацией огромных денежных сумм при ошибках в программном обеспечении прикладного уровня.
    Предупреждение фискализации (отладка)
    если этот флаг установлен, то при работе программы на экран выдаются дополнительные предупреждения перед выполнением фискализируемых операций (продажа, закрытие чека, отчёт с гашением). Используйте этот флаг при отладке программного обеспечения прикладного уровня. При нормальной эксплуатации он должен быть снят.
    Последняя строка чека
    закрывающая строка чека фискального регистратора (от 0 до 40 символов) (печатается перед строкой, содержащей итоговую сумму чека)
    Дополнительный прогон чека
    дополнительный прогон чековой ленты после отрезки чека. Эта функция может использоваться для борьбы с некоторыми видами замятия чековой ленты.
    Макс. длина строки печати, знаков
    Максимальная длина строки печати в знаках -это значение используется для программного разбиения/переноса длинных строк (строка разбивается по знакам, разрыв слов и чисел - возможен).
    Фискальный регистратор имеет собственное ограничение максимальной длины одной строки печати, если его превысить, то либо строка будет обрезана, либо произойдёт ошибка печати (в зависимости от настроек и возможностей используемого оборудования).
    Значение по умолчанию - 39.

    Совместимость: управление максимальной длиной строки печати в диалоге параметров фискального регистратора поддерживается в NDemia CashMatic, начиная с версии 2.7.0 (ранее действовало постоянное ограничение 39 знаков)

    Отрезка чека
    настройка отрезки чека после печати (полная или частичная). (Примечание: драйвер фискального регистратора в ряде случаев может игнорировать этот параметр)
    Использовать коды форматирования
    отключение этого флажка предписывает не удалять (пропускать на выход без обработки) коды форматирования ( коды) при печати без шаблона. (см. Руководство прикладного программиста).


Свойства

В NDemia CashMatic поддерживаются фискальные регистраторы производства "Штрих-М" (http://www.shtrih-m.ru), которые комплектуются собственным драйвером с достаточно развитой настройкой ("Драйвер ФР").
Диалог свойств поддерживается самим драйвером (документацию см. на сайте www.shtrih-m.ru). Приведённая иллюстрация является только примером возможного диалога свойств, конкретный вид диалога зависит от версии установленного на компьютере "Драйвера ФР".
Диалог вызывается со страницы настройки принтера Панели управления NDemia CashMatic кнопкой Свойства в разделе режима "Фискальный регистратор".


Дополнительные сведения по настройке

Перезапуск программных компонентов в результате изменения параметров;
Использование команды CONFIG.


Перезапуск программных компонентов в результате изменения параметров

В результате изменения параметров на страницах Панели управления NDemia CashMatic программное обеспечение может принять решение перезапустить службу NDemia CashMatic Kiosk и/или приложение NDemia CashMatic KioskBrowser. Хотя такой перезапуск является штатно предусмотренным, рекомендуется перед запуском Панели управления если не закрывать NDemia CashMatic KioskBrowser, то хотя бы выводить платёжный интерфейс в некоторое положение, безопасное с точки зрения возможного внезапного перезапуска с потерей текущих данных. Например, обеспечить, чтобы интерфейс не находился в это время в положении незавершённого платежа. Кроме того, интерфейс может находиться в положении модального диалога, вызванного компонентом расширения или прикладным скриптом, в том числе сформированным на сервере, это может помешать приложению перезапуститься. Поэтому автоматический перезапуск приложения в результате изменения настройки хотя и делается, но успех его не гарантирован. В случае неуспеха нужно перезапустить приложение вручную.


Использование команды CONFIG

В случае использования службы NDemia CashMatic Kiosk большинство параметров, конфигурируемых в Панели управления NDemia CashMatic, может также быть настроено с помощью программы CONFIG, которую можно вызывать из командной строки, из командных скриптов и из других программ. Более подробно эта команда описана в Руководстве прикладного программиста.


Меню NDemia CashMatic

NDemia CashMatic в Проводнике Windows (меню "Пуск")
NDemia CashMatic в панели задач Windows


NDemia CashMatic в Проводнике Windows (меню "Пуск")

Инсталлятор NDemia CashMatic создаёт на рабочем столе Windows и в списке программ меню Пуск Windows ярлыки основного приложения (NDemia CashMatic KioskBrowser) и Панели управления NDemia CashMatic.

Ссылка на Панель управления NDemia CashMatic добавляется в панель управления Windows.
Инсталлятор NDemia CashMatic создаёт в меню Пуск Windows папку NDemia\CashMatic.
Эта папка содержит следующие ярлыки:
Пункт меню | Действие
NDemia CashMatic KioskBrowser | Запуск приложения NDemia CashMatic KioskBrowser
Панель управления NDemia CashMatic | Открыть Панель управления NDemia CashMatic
Текущая информация | Ссылки на файл последних изменений ReadMe в различных форматах
Апплет панели задач | Запуск CMStartApp - приложения NDemia CashMatic для панели задач Windows
Регистрация программного продукта | Запуск программы регистрации программного продукта
Активация лицензионного ключа | Запуск программы регистрации в режиме активации лицензионного ключа
Папка программного продукта | Открыть в Проводнике Windows папку установки программного продукта NDemia CashMatic (обычно: %ProgramFiles%\NDemia\CashMatic)
Руководство по эксплуатации | Справка по использованию продукта NDemia CashMatic
Руководство прикладного программиста | Справка по программированию на основе NDemia CashMatic KioskBrowser
Сайт продукта | Открыть официальный сайт продукта NDemia CashMatic: http://www.ndemia.com/CashMatic
Удаление NDemia CashMatic | Запуск программы удаления программного продукта NDemia CashMatic (Uninstall) Совместимость: удаление добавляется в меню NDemia CashMatic, начиная с версии 2.7.2.


NDemia CashMatic в панели задач Windows

Значок NDemia CashMatic [image] в панели задач Windows создаётся специальным приложением CMStartApp.exe. Основные цели, выполняемые этой программой:
  • отслеживание и индикация изменений лицензии;
  • быстрый запуск основных приложений NDemia CashMatic;
  • обеспечение доступа к справочным материалам, информации о программе и обновлениях.

Постоянное использование CMStartApp в общем не обязательно, однако она представляется полезным организующим элементом и потребляет достаточно мало ресурсов, поэтому рекомендуется её не отключать. Что касается контроля испытательного срока, эта программа является только средством индикации и напоминания, её отключение не влияет на поведение остальных компонентов NDemia CashMatic.
Меню значка панели задач Windows открывается щелчком правой кнопки мыши по значку и содержит следующие пункты:
Пункт меню | Действие
Закрыть меню | закрыть меню, не выполняя никаких действий
NDemia CashMatic KioskBrowser | запуск приложения NDemia CashMatic KioskBrowser (если приложение в данный момент уже выполняется, данный пункт отмечается галочкой)
Панель управления NDemia CashMatic | открыть Панель управления NDemia CashMatic (если Панель управления в данный момент уже открыта, данный пункт отмечается галочкой)
Регистрация продукта | запуск программы регистрации программного продукта
Активация лицензионного ключа | запуск программы регистрации в режиме активации лицензионного ключа
Руководство по эксплуатации | Справка по использованию продукта
Руководство прикладного программиста | Справка по программированию на основе NDemia CashMatic KioskBrowser
Сайт продукта | переход на веб-страницу программного продукта, используется умолчательный интернет-браузер Вашего компьютера
О программе | диалог сведений о программе.
Проверка обновлений | проверка наличия обновлений для Вашей версии программного продукта NDemia CashMatic на сервере ООО НДемиа
Запускать автоматически | режим автоматического запуска CMStartApp при загрузке операционной системы (если автоматический запуск включен, данный пункт отмечается галочкой)
Выход | завершить работу CMStartApp (не влияет на остальные компоненты NDemia CashMatic)

Жирным шрифтом выделяется пункт меню, выполняемый по умолчанию (при двойном щелчке левой кнопки мыши по значку). В зависимости от текущей ситуации это может быть NDemia CashMatic KioskBrowser, Регистрация продукта или Активация лицензионного ключа.


Регистрация

Если Вы уже приобрели лицензионный ключ, то можете пропустить чтение данного раздела настоящего Руководства - Вам не нужно выполнять процедуру регистрации, поскольку активация лицензионного ключа её целиком заменяет.
Регистрация программного продукта NDemia CashMatic является полностью анонимной процедурой, в ходе которой на сервере ООО НДемиа создаётся учётная запись Вашего экземпляра программы. Целью регистрации является техническое обеспечение права пользователей использовать программный продукт бесплатно в течение испытательного срока и продолжать использовать тот же продукт без каких-либо изменений функциональности после его покупки. После первой установки программы на компьютер регистрация необходима, незарегистрированный продукт работать не будет. Испытательный срок бесплатной эксплуатации программы отсчитывается от момента выполнения регистрации.
Вызвать процедуру регистрации можно следующими способами:
  • из меню Пуск (Все программы\NDemia\CashMatic\Регистрация программного продукта)
  • из меню значка NDemia CashMatic в панели задач Windows
  • из Панели управления NDemia CashMatic (страница Лицензия, кнопка "Регистрация продукта и активация ключа")
  • папка установки программы, файл CMRegUI ("\Program Files\NDemia\CashMatic\CMRegUI.exe")

(все способы запуска равнозначны)
Регистрация программы выполняется через интернет, поэтому компьютер или терминал должен на время регистрации иметь подключение к интернету, должен быть доступен сервер http://www.ndemia.com.
Часы реального времени компьютера (время и дата) должны быть относительно точно настроены (достаточно точности в человеческом понимании, т.е. в пределах минут), если отклонение будет очень большим - сервер может отказаться от регистрации.
Нормальное выполнение регистрации не требует от пользователя никаких дополнительных действий, за исключением подтверждения разрешения на передачу конфиденциальной информации. Всю информацию, получаемую с компьютера пользователя в ходе регистрации, ООО НДемиа без дополнительных согласований считает конфиденциальной информацией пользователя. Вся отправляемая информация в обязательном порядке будет показана пользователю перед отправкой (за исключением внутренней информации программного продукта). При этом также будет показано Заявление о политике конфиденциальности - пожалуйста, ознакомьтесь с ним внимательно перед принятием решения.

Регистрация является действительно анонимной, поэтому после её выполнения Вы не можете что-либо изменить или отозвать.
Можно ли выполнить регистрацию при отказе пользователя от передачи конфиденциальной информации, и что будет в этом случае - это управляется текущей политикой сервера и может изменяться во времени, поэтому настоящее Руководство оговаривает этот вопрос лишь в общих чертах. Внимательно смотрите текст в диалоговом окне при подтверждении разрешения на передачу информации - там всё будет написано подробно и точно. На момент выхода настоящего Руководства основной политикой при отказе пользователя является разрешение регистрации без передачи информации об оборудовании, но в этом случае программный продукт блокируется на длительный срок (не менее суток), по истечении этого срока нужно будет выполнить повторную регистрацию (при этом можно снова отказаться от передачи конфиденциальной информации, блокирования уже не будет).
Если Вы используете купюроприёмник с протоколом управления CCNET, то при регистрации программного продукта он должен быть подключен (и выполнена соответствующая настройка - см. Панель управления NDemia CashMatic, вкладка Купюроприёмник). Обязательным условием лицензирования NDemia CashMatic при использовании CCNET является привязка лицензии к конкретному купюроприёмнику. Эта привязка должна быть выполнена при регистрации в обязательном порядке, даже если Вы отказываетесь от передачи сведений об оборудовании на сервер (привязка может быть выполнена локально на Вашем компьютере).
Если при регистрации программа не сможет связаться с купюроприёмником, Вам будет выдано соответствующее предупреждение:

Если по каким-либо причинам в момент регистрации купюроприёмник не был подключен (или был подключен другой купюроприёмник), то для последующего использования купюроприёмника потребуется новая регистрация.

Если всё в порядке и регистрация программного продукта выполнена успешно, то Вы увидите сообщение:

Обратите внимание - Ваш экземпляр программного продукта действительно регистрируется в базе данных на сервере, и впоследствии он может быть "узнан" в ряде случаев даже после переустановки Windows. Право бесплатного использования полнофункционального программного продукта предоставляется только на испытательный срок и прекращается после окончания испытательного срока.
Если регистрация выполняется после окончания испытательного срока (по мнению сервера), то выдаётся следующее сообщение:

"Регистрация выполнена успешно" в данном случае означает, что все необходимые данные были получены, и обмен информацией с сервером произошёл нормально. Однако для работы программного продукта требуется активация лицензионного ключа.

Если процедура регистрации будет вызвана пользователем без необходимости (когда она не требуется) - по ошибке или, наоборот, для проверки подлинности лицензии, то об этом будет выдано соответствующее сообщение:

Гарантированной политикой в данном случае является указанное в сообщении: если в ходе необязательной регистрации лицензия по каким-либо причинам не будет подтверждена, то никаких ограничений к программному продукту применено не будет (сообщение представителю ООО НДемиа только указывает, что факт имел место, оно не может быть соотнесено с конкретным компьютером или пользователем).

При регистрации программного продукта Вы можете столкнуться со следующими проблемами:
  1. заблокированная лицензия;
  2. отказ запуска службы NDemia CashMatic Kiosk;
  3. отказ сервера выполнить регистрацию.

Лицензия может оказаться заблокированной по целому ряду причин, основные из них:
  • временное блокирование после регистрации без передачи конфиденциальной информации (активируйте лицензионный ключ, или дождитесь конца периода блокирования и запустите регистрацию ещё раз);
  • истечение испытательного срока (активируйте лицензионный ключ);
  • переустановка программы после неполного удаления (активируйте лицензионный ключ, или удалите программу полностью и установите заново).

В любом случае, если лицензия заблокирована, программа регистрации не станет вообще обращаться на сервер.

Служба NDemia CashMatic Kiosk требуется программе регистрации для получения протокола купюроприёмника и идентификационных данных купюроприёмника.
Отказ запуска службы NDemia CashMatic Kiosk может произойти по ряду причин, связанных с настройками Вашей операционной системы, с последовательностью ряда переустановок программного продукта, и т.п. - в любом случае Вам потребуется дополнительная техническая поддержка.

Примечание: код ошибки и формулировка ошибки могут отличаться от приведённых на иллюстрации

Совместимость: данное сообщение поддерживается в NDemia CashMatic, начиная с версии 2.7.0

Причина отказа сервера пользователю не сообщается, выдаётся только сообщение:

(заметим, что со стороны сервера временное блокирование и истечение испытательного срока причинами для отказа не являются, в этих случаях регистрация считается выполненной "успешно, но с особыми параметрами") В любом случае, если Вам отказано в регистрации - обращайтесь за поддержкой.
Активация лицензионного ключа имеет шанс пройти и через отказ сервера в регистрации.

Как уже сказано выше - если у Вас есть лицензионный ключ, сразу переходите к активации. Активация полностью включает в себя все действия по регистрации, более того, если сервер признает активацию легальной, то все проблемы с блокировкой лицензии будут автоматически скорректированы.


Запуск NDemia CashMatic KioskBrowser

Запуск основного приложения программного продукта NDemia CashMatic может быть выполнен следующими способами:
  • из меню Пуск (Все программы\NDemia\CashMatic\NDemia CashMatic KioskBrowser)
  • автоматически при загрузке Windows (управляется флажком "Автозапуск при загрузке системы" на вкладке Интерфейс в Панели управления NDemia CashMatic)
  • из меню значка NDemia CashMatic в панели задач Windows
  • папка установки программы, файл KioskBrowser ("\Program Files\NDemia\CashMatic\KioskBrowser.exe")

(все способы запуска равнозначны)

При запуске сразу открывается стартовая страница прикладной системы - специальный адрес "start" (см. Модель навигации в Руководстве прикладного программиста)

Обратите внимание - окно NDemia CashMatic KioskBrowser всегда развёрнуто в полный экран и не имеет никаких кнопок управления (всё управление должно быть предусмотрено в прикладной системе), поэтому завершить его работу можно только нажатием клавиш Alt+F4 (без клавиатуры невозможно вообще, если не использовать специальных программ типа Диспетчера задач Windows). При наличии клавиатуры переключаться на другие окна следует нажатием Alt+Tab.
Если в Панели управления NDemia CashMatic на вкладке Интерфейс установлен флажок "Отдельный рабочий стол", завершить работу приложения можно только по Alt+F4 (даже Диспетчер задач, вызываемый по Ctrl+Alt+Del, будет скрыт за окном NDemia CashMatic KioskBrowser).
Если в Панели управления NDemia CashMatic на вкладке Интерфейс установлен флажок "Автозапуск при загрузке системы", то без клавиатуры выйти из NDemia CashMatic KioskBrowser в Windows будет невозможно в принципе, даже перезагрузкой по кнопке Reset.
Учитывая всё это, крайне рекомендуется для выполнения любых технологических работ на терминале подключать клавиатуру.


Активация

Активация лицензионного ключа необходима для подтверждения приобретения Вами лицензии на использование программного продукта NDemia CashMatic.
В результате активации Ваш экземпляр программного продукта будет отмечен на учётном сервере ООО НДемиа как принятый в эксплуатацию, а на Вашем компьютере будут изменены лицензионные данные программного продукта в соответствии с параметрами приобретённой Вами лицензии.
Если у Вас ещё нет лицензионного ключа, но Вы хотели бы использовать программный продукт NDemia CashMatic на постоянной основе, то Вам необходимо приобрести соответствующую лицензию. Для получения информации о покупке программы посетите сайт ООО НДемиа: http://www.ndemia.com/CashMatic/how2buy.

Если у Вас есть лицензионный ключ, то активация ключа может быть выполнена в любой момент, начиная с установки программного продукта на компьютере или терминале: до регистрации (вместо регистрации), во время испытательного срока (включая период временного блокирования лицензии), по истечению испытательного срока. Активация ключа может выполняться многократно, повторная активация называется реактивацией, подробности см. ниже.

Процедура активации выполняется программой регистрации программного продукта (CMRegUI).
Вызвать процедуру активации можно следующими способами:
  • из меню Пуск (Все программы\NDemia\CashMatic\Активация лицензионного ключа)
  • из меню значка NDemia CashMatic в панели задач Windows
  • из Панели управления NDemia CashMatic (страница Лицензия, кнопка "Регистрация продукта и активация ключа")
  • папка установки программы, файл CMRegUI ("\Program Files\NDemia\CashMatic\CMRegUI.exe")

(все способы запуска равнозначны)

При наличии лицензионного ключа отдельная регистрация программного продукта не требуется - она будет выполнена в ходе активации ключа.

Если при запуске программы регистрации не определяется ближайшее необходимое действие, то будет показан диалог выбора действия.
Такой:

или такой (текст сообщения может отличаться):

Активация ключа выполняется через интернет, поэтому компьютер или терминал должен на время активации иметь подключение к интернету, должен быть доступен сервер http://www.ndemia.com.
Часы реального времени компьютера (время и дата) должны быть относительно точно настроены (достаточно точности в человеческом понимании, т.е. в пределах минут), если отклонение будет очень большим - сервер может отказаться от активации.
Нормальное выполнение активации не требует от пользователя никаких дополнительных действий, за исключением подтверждения разрешения на передачу конфиденциальной информации. Всю информацию, получаемую с компьютера пользователя в ходе активации, ООО НДемиа без дополнительных согласований считает конфиденциальной информацией пользователя. Вся отправляемая информация в обязательном порядке будет показана пользователю перед отправкой (за исключением внутренней информации программного продукта). При этом также будет показано Заявление о политике конфиденциальности - пожалуйста, ознакомьтесь с ним внимательно перед принятием решения.

Активация является действительно анонимной, поэтому после её выполнения Вы не можете что-либо изменить или отозвать.
Можно ли выполнить активацию при отказе пользователя от передачи конфиденциальной информации, и что будет в этом случае - это управляется текущей политикой сервера и может изменяться во времени, поэтому настоящее Руководство оговаривает этот вопрос лишь в общих чертах. Внимательно смотрите текст в диалоговом окне при подтверждении разрешения на передачу информации - там всё будет написано подробно и точно. На момент выхода настоящего Руководства основной политикой при отказе пользователя является разрешение активации без передачи информации об оборудовании, но в этом случае повторное использование активируемого ключа запрещается на длительный срок (не менее трёх суток), т.е. его нельзя будет активировать ещё раз даже на том же самом компьютере.

Для получения протокола купюроприёмника и идентификационных данных купюроприёмника программе активации требуется доступ к службе NDemia CashMatic Kiosk.
Отказ запуска службы NDemia CashMatic Kiosk может произойти по ряду причин, связанных с настройками Вашей операционной системы, с последовательностью ряда переустановок программного продукта, и т.п. - в любом случае Вам потребуется дополнительная техническая поддержка.

Примечание: код ошибки и формулировка ошибки могут отличаться от приведённых на иллюстрации

Совместимость: данное сообщение поддерживается в NDemia CashMatic, начиная с версии 2.7.0

Если Вы используете купюроприёмник с протоколом управления CCNET, то при активации лицензионного ключа он должен быть подключен (и выполнена соответствующая настройка - см. Панель управления NDemia CashMatic, вкладка Купюроприёмник). Обязательным условием лицензирования NDemia CashMatic при использовании CCNET является привязка лицензии к конкретному купюроприёмнику. Эта привязка должна быть выполнена при активации в обязательном порядке, даже если Вы отказываетесь от передачи сведений об оборудовании на сервер (привязка может быть выполнена локально на Вашем компьютере).
Если при активации программа не сможет связаться с купюроприёмником, Вам будет выдано соответствующее предупреждение:

Если по каким-либо причинам в момент активации купюроприёмник не был подключен (или был подключен другой купюроприёмник), то для последующего использования купюроприёмника потребуется новая активация.

Если всё в порядке и активация лицензионного ключа выполнена успешно, то Вы увидите сообщение:

Повторная активация ключа на том же самом экземпляре Windows и том же самом оборудовании разрешается неограниченное число раз. (необходимость этого может возникнуть, например, при удалении и повторной установке программного продукта)
Повторная активация ключа при изменении идентификации операционной системы или оборудования в принципе возможна, но ограниченное число раз (конкретное ограничение регламентируется текущей политикой учётного сервера). По истечении разрешённого числа реактиваций Вам потребуется обращение в ООО НДемиа. Обратите внимание: техническая возможность активировать один и тот же ключ на разных комплектах оборудования сама по себе не означает разрешения использования одного экземпляра программного продукта одновременно на нескольких терминалах.

Если Вы официально приобрели программный продукт NDemia CashMatic, то ключ Вам обязательно передан продавцом в печатном виде, кроме того, возможно, Вы получили ключ в электронном виде (как текст - по электронной почте и т.п.).

Ключ представляет собой комбинацию из десятичных цифр и букв латинского алфавита (4 группы по 4 знака, группы разделены знаками "-" (дефис или минус), без пробелов).
Введите ключ так, как он напечатан. Если у Вас есть текст ключа в электронном виде, можно воспользоваться копированием-вставкой.
Если Вы ошибётесь при вводе ключа - ничего страшного. Программа активации ключа сообщит об ошибке ещё до отправки ключа на сервер, у Вас будет возможность ввести ключ повторно.
Далее, если сервер признает ключ правильным, Вам будет выдано сообщение об успешной активации.
Если сервер почему-либо откажется принять ключ, Вам будет предложено обратиться в ООО НДемиа за дополнительной технической поддержкой.

В отдельных случаях (при особых вариантах продажи, или в порядке сопровождения программного продукта - по указанию представителя ООО НДемиа) возможно применение лицензионного ключа без активации и без обращения на учётный сервер ООО НДемиа. Для этого Вы должны иметь специальный лицензионный ключ и соответствующий ему файл лицензионных данных. В диалоге выбора действия программы регистрации выберите пункт "Хочу ввести вручную ключ лицензии и файл лицензионных данных"

Далее будет показан диалог "Обновить лицензию NDemia CashMatic"

В поле "Ключ" нужно ввести лицензионный ключ (можно воспользоваться копированием-вставкой). Если нажать на кнопку "Ключ", раскроется меню с некоторыми дополнительными действиями:
    "Хочу запросить ключ"
    вызывается умолчательный почтовый клиент Вашего компьютера для формирования письма с запросом ключа в ООО НДемиа.
    "Не хочу менять ключ"
    оставить действующий ключ без изменения, изменить только файл лицензионных данных.

В поле "Файл" нужно ввести полное имя файла лицензионных данных. Если нажать на кнопку "Файл", раскроется меню с некоторыми дополнительными действиями:
    "Хочу выбрать файл"
    выбор файла через диалог открытия;
    "Не хочу менять файл"
    оставить действующие лицензионные данные без изменения, изменить только ключ.

Если Вы вводите лицензионный ключ и/или указываете файл лицензионных данных, то после нажатия Ok будет выполнена попытка применить введённые данные.
В случае успеха будет выдано сообщение:

Совместимость: данное сообщение поддерживается в NDemia CashMatic, начиная с версии 2.7.1

В случае отрицательного результата (ошибка в ключе, неправильный файл лицензионных данных и т.п.) лицензия станет недоступной, будет снова показан диалог выбора действия, из которого Вы можете повторить попытку ввода.


Проверка обновлений

Проверка наличия обновлений для текущей установленной версии программного продукта на сервере NDemia делается по команде "Проверка обновлений" меню значка панели задач Windows.
Проверка обновлений выполняется через интернет, поэтому компьютер или терминал должен на время этой проверки иметь подключение к интернету, должен быть доступен сервер http://www.ndemia.com.

Если у Вас установлен самый новый выпуск программного продукта (и обновлений для него на сервере нет), Вам будет показано сообщение:

Если почему-либо сервер не может определить, доступны ли обновления для Вашего выпуска, Вам будет показано сообшение:

Если на сервере имеется доступное обновление для Вашего выпуска программного продукта, Вам будет предложено его загрузить и установить.


Удаление

Для удаления программного продукта NDemia CashMatic KioskBrowser используйте соответствующий элемент панели управления Windows: «Программы и компоненты» (в Windows XP: «Установка и удаление программ»). Кроме того, Вы можете вызвать программу удаления из меню NDemia CashMatic в Проводнике Windows (меню «Пуск»).

Совместимость: удаление добавляется в меню NDemia CashMatic, начиная с версии 2.7.2.

При вызове программы удаления Вам будет предложено выбрать параметры удаления:
    Удалить файлы и папки, созданные при установке программы
    по этому флажку удаляются файлы, для которых есть информация об их установке. При установке программы составляется список всех файлов, которые были скопированы, заменены, сохранены без изменения и т.п. Список пополняется при каждой последующей переустановке, установке обновлений и новых версий.
    Удалить настройки и параметры, записанные в системном реестре
    по этому флажку удаляются все разделы NDemia CashMatic, созданные в системном реестре Windows.
    Полностью удалить все файлы и данные, связанные с программным продуктом
    это наиболее жёсткий режим удаления, в результате не должно остаться никаких записей в реестре и никаких файлов и папок, связанных с программным продуктом. ВНИМАНИЕ: если Вы создавали или изменяли какие-либо файлы в папке установки программы ("\Program Files\NDemia\CashMatic") или её подпапках, то обязательно сохраните эти файлы вне путей, связанных с программой, иначе все Ваши данные будут безвозвратно удалены.
    Режим "Полностью удалить..." можно вызвать даже после неполного удаления (если Вы сохранили или загрузили с сайта NDemia деинсталлятор Uninstall.exe) для окончательной зачистки, в этом режиме деинсталлятор может выдать предупреждения об отсутствии тех или иных записей и данных об установке программы, но всё равно полное удаление будет выполнено (на основании известных деинсталлятору умолчаний).

Если Вы собираетесь позднее установить программу обратно, и у Вас ещё нет лицензионного ключа, то выбирайте либо полное удаление, либо удаляйте файлы и папки без удаления информации из реестра. В противном случае повторная установка использует неверные лицензионные данные, и программный продукт потребует активации лицензионного ключа.
Не используйте удаление и переустановку программного продукта для продления испытательного срока - испытательный срок отсчитывается только от первой установки программы на компьютер или терминал.


Дополнительная информация

В комплект программного продукта NDemia CashMatic KioskBrowser входит следующая документация:
Руководство по эксплуатации | настоящее Руководство
Руководство прикладного программиста | содержит справочные материалы по разработке прикладных систем приёма платежей на основе NDemia CashMatic KioskBrowser.
ReadMe.txt | текущая техническая информация

Дополнительная информация публикуется на сайте ООО НДемиа
Официальный сайт компании ООО НДемиа: | http://www.ndemia.com
Страница программного продукта NDemia CashMatic: | http://www.ndemia.com/CashMatic